Chromecast - Panasonic TH-42PZ80Q - Not Working

fear_nothing

Limp Gawd
Joined
Jun 28, 2002
Messages
161
Got a Google chromecast device last night, can't for the life of me get the damn thing to work. Even broke down and called Google. file that under *look in the dictionary for waste of time*

Device is fine, works on another TV.
HDMI ports on said TV both work (tested with other multiple other inputs as a source)

On the TV in questions is a Panasonic TH-42PZ80Q
-42 inch plasma
-2 HDMI ports

Occasionally I get catch it on POST stating" Chromecast Booting"

Not much Google chatter on this topic.

If I had it guess it has to do with the viera link.

Any help is appreciated!
 

ob1

2[H]4U
Joined
Apr 17, 2000
Messages
2,274
With or without the usb dongle plugged in, and if plugged, into TV or wall outlet?
 

fear_nothing

Limp Gawd
Joined
Jun 28, 2002
Messages
161
Guess I should have mentioned that :rolleyes:

-tried USB power from a laptop
-tried the OEM charger + wall power
-tried another micro usb charger + wall power

all equals an unsatisfied Chromecast user:confused:
 
Last edited:

mi7chy

2[H]4U
Joined
May 22, 2013
Messages
3,985
Maybe check if there's a firmware update available via SD card slot. My guess the 2008 TV is the issue and not the Chromecast.
 

ob1

2[H]4U
Joined
Apr 17, 2000
Messages
2,274
I honestly didn't mean it that way, as I have a new 2013 model year Samsung plasma with HDMI1.4 and it does not power the chromecast. I have to use the dongle to power the thing. Just making sure.
 

Adidas4275

Supreme [H]ardness
Joined
Mar 11, 2006
Messages
5,986
google didnt make the chromecast to be powered by MHL HDMI ports :(

but my working chromecast that i have used in the past on other devices was causing issues with my new epson 3500 as well. the epson locked up and would not accept any signal from either HDMI inputs when the chromecast was installed
 
Top