Chrome hanging in Windows 10 Home edition

GT98

[H]ard|Gawd
Joined
Aug 29, 2001
Messages
1,251
I keep getting beset by Chrome not responding errors on my Dell Inspiron 15 7559 laptop. I've uninstalled/reinstalled 32 and 64 bit versions, disabled my extensions, reset chrome and its still hanging at times. I use the same Chrome on my Surface Pro, Desktop and even my work Laptop (which has even lower specs then my gaming laptop) without no issue. The only thing I can come up with is that I'm running Windows 10 Home Edition on the Insprion, and the other systems are either Win10 Professional or Windows 7 Professional (work laptop).

Any other suggestions?
 

primetime

Supreme [H]ardness
Joined
Aug 17, 2005
Messages
6,736
Last time i remember seeing chrome having those kind of issues was the early days of windows 8. Maybe its not liking some program running in the background?
 

Krixon

Limp Gawd
Joined
Mar 21, 2015
Messages
371
I have been having the exact same issue on my Surface Pro 3 for the past few days. For about 10 seconds every ~hour, Chrome will just stop responding to anything. Also tried reinstalling 32/64 bit versions and even rolling back to a restore point 5 days ago. No dice so far.
 

primetime

Supreme [H]ardness
Joined
Aug 17, 2005
Messages
6,736
for you guys having the issues.....maybe try Chrome Canary? I would only use it if the current version is having issues....if this has no effect it has to be something else on your pc causing it
 

rezerekted

2[H]4U
Joined
Apr 6, 2015
Messages
3,043
I'm getting the same since last update to Opera, which is a chrome browser. It will stop responding for a brief period then recover. Someone has screwed the pooch and it isn't my PC. Maybe one of those Windows updates or the browser updates caused it.

I use Chromium browser in Linux on the same PC and no such issues there. It's fucking Windows that is the issue, IMO. Or I guess it could be Avast causing it when it checks the pages for malware. Something besides my hardware is causing it and I want it resolved ASAP.

Could even be Microsoft telemetry BS causing it.
 

primetime

Supreme [H]ardness
Joined
Aug 17, 2005
Messages
6,736
I'm getting the same since last update to Opera, which is a chrome browser. It will stop responding for a brief period then recover. Someone has screwed the pooch and it isn't my PC. Maybe one of those Windows updates or the browser updates caused it.

I use Chromium browser in Linux on the same PC and no such issues there. It's fucking Windows that is the issue, IMO. Or I guess it could be Avast causing it when it checks the pages for malware. Something besides my hardware is causing it and I want it resolved ASAP.

Could even be Microsoft telemetry BS causing it.
It absolutely could be avast....And on top of that Modern day defender has been working great on my setups.Not a single infection in years, and every once in a while i run several tests (from other programs) just to double check....Not even weak spyware. Course it could have a lot to do with my internet habits these days, as in being more careful. Anyways Avast is certainly a decent idea to check. If it were a MS update, it would effect more of us i think? Have to figure out what aside from chrome is common between you guys. How many people here having the issue are using 3rd party security software?
 
Top