CCENT Help - RIPv2 Routing

Karandras

[H]ard|Gawd
Joined
Feb 16, 2001
Messages
1,873
Hey, first off here is the network diagram

https://docs.google.com/open?id=0B2boM7sqerOocVdlTEFuNncyRzA

Now here are the running configs:

Code:
#####################--R1--#####################
R1#sh run
Building configuration...

Current configuration : 1855 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$tLJK$cW73oZr6Hs2V34YcTuCwR0
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip domain name testnetwork.local
ip name-server 10.0.0.1
!
!
password encryption aes
!
!
username admin secret 5 $1$TJa8$h.SYIPdEDTJZ69qZn1pIj/
username test password 7 0204085A03
username R2 password 7 1511030D1429232538
username R3 password 7 01100E054B080E0E31
!
!
ip ssh version 1
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0
 description Serial Link to R2
 ip address 192.168.0.0 255.255.255.254
 ip nat inside
 ip virtual-reassembly
 encapsulation ppp
 no fair-queue
 clock rate 512000
 ppp authentication ms-chap-v2 local
!
interface FastEthernet0/1
 ip address 10.0.0.254 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial0/1
 description Serial Link to R3
 ip address 192.168.0.2 255.255.255.254
 ip nat inside
 ip virtual-reassembly
 encapsulation ppp
 clock rate 64000
 ppp authentication ms-chap-v2 local
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.0.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.0.1
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 172.16.0.0 0.0.255.255
access-list 1 permit 192.168.0.0 0.0.0.255
!
!
control-plane
!
!
!
banner motd ^C
If you are not authorized to be here, log off now!



^C
!
line con 0
line aux 0
line vty 0 4
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
!
!
end


#####################--R2--#####################
R2#sh run
Building configuration...

Current configuration : 1364 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$tLJK$cW73oZr6Hs2V34YcTuCwR0
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
ip domain name testnetwork.local
ip name-server 10.0.0.1
!
multilink bundle-name authenticated
!
!
!
!
!
username admin secret 5 $1$TJa8$h.SYIPdEDTJZ69qZn1pIj/
username R1 password 7 110A11040711030D14
username R3 password 7 00071B07145803071F
archive
 log config
  hidekeys
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.16.31.254 255.255.240.0
 duplex auto
 speed auto
!
interface Serial0/0
 description Serial Link to R1
 ip address 192.168.0.1 255.255.255.254
 encapsulation ppp
 no fair-queue
 ppp authentication ms-chap-v2 local
!
interface Serial0/1
 description Serial Link to R3
 ip address 192.168.0.4 255.255.255.254
 encapsulation ppp
 clock rate 512000
 ppp authentication ms-chap-v2 local
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.0.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.0.254
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
!
!
end

#####################--R3--#####################
R3#sh run
Building configuration...

Current configuration : 1345 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$tLJK$cW73oZr6Hs2V34YcTuCwR0
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
ip domain name testnetwork.local
ip name-server 10.0.0.1
!
multilink bundle-name authenticated
!
!
!
!
!
username admin secret 5 $1$TJa8$h.SYIPdEDTJZ69qZn1pIj/
username R1 password 7 104D011815141A0A1C
username R2 password 7 060507205C4D011815
archive
 log config
  hidekeys
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 172.16.47.254 255.255.240.0
 duplex auto
 speed auto
!
interface Serial0/0
 description Serial Link to R2
 ip address 192.168.0.5 255.255.255.254
 encapsulation ppp
 no fair-queue
 ppp authentication ms-chap-v2 local
!
interface Serial0/1
 description Serial Link to R1
 ip address 192.168.0.3 255.255.255.254
 encapsulation ppp
 ppp authentication ms-chap-v2 local
!
router rip
 version 2
 network 172.16.0.0
 network 192.168.0.0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.0.254
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
!
!
end

Now the problem. This network works I can ping everything inside and get out to the internet with R1 perfoming NAT. The problem comes when I disconnect the serial cable between R2 and R3. Trying to ping from TopSwitch -> Bottom Switch stops and doesn't come back. With RIPv2 shouldn't the logical path be recreated and packets start flowing from TopSwitch -> R2 -> R1 -> R3 -> BottomSwitch ?

Or if there is a config problem, please inform me. OR even better, if there is a debug that I can use to possibly find the issue with the config myself then that would be more helpful in the learning process...more frustrating but way gooder in the end ;-)

Thanks!
 
How long are you waiting? It sometimes takes a bit to get the new routes set. What if you do a tracert before disconnecting? What path is it taking? What does show ip route look like? Do you see both routes in the table?

I'm looking at this on a phone so I can't really see the diagram. I was going to suggest looking at STP but it appears there are no redundant switch links.
 
How long are you waiting? It sometimes takes a bit to get the new routes set. What if you do a tracert before disconnecting? What path is it taking? What does show ip route look like? Do you see both routes in the table?

I'm looking at this on a phone so I can't really see the diagram. I was going to suggest looking at STP but it appears there are no redundant switch links.

How long are you waiting? - Upwards of 10-15 min

Before the unplug:
Code:
TopSwitch#traceroute 172.16.32.2

Type escape sequence to abort.
Tracing the route to 172.16.32.2

  1 172.16.31.254 4 msec 4 msec 4 msec
  2 192.168.0.5 4 msec 4 msec 4 msec
  3 172.16.32.2 4 msec *  4 msec

#####################--R1--#####################
R1#sh ip route
Gateway of last resort is 10.0.0.1 to network 0.0.0.0

R    172.16.0.0/16 [120/1] via 192.168.0.3, 00:00:04, Serial0/1
                   [120/1] via 192.168.0.1, 00:00:24, Serial0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/1
     192.168.0.0/24 is variably subnetted, 7 subnets, 2 masks
C       192.168.0.0/31 is directly connected, Serial0/0
C       192.168.0.1/32 is directly connected, Serial0/0
C       192.168.0.2/31 is directly connected, Serial0/1
C       192.168.0.3/32 is directly connected, Serial0/1
R       192.168.0.4/32 [120/1] via 192.168.0.3, 00:00:04, Serial0/1
R       192.168.0.4/31 [120/1] via 192.168.0.3, 00:00:04, Serial0/1
                       [120/1] via 192.168.0.1, 00:00:24, Serial0/0
R       192.168.0.5/32 [120/1] via 192.168.0.1, 00:00:24, Serial0/0
S*   0.0.0.0/0 [1/0] via 10.0.0.1

#####################--R2--#####################
R2#sh ip route
Gateway of last resort is 10.0.0.254 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.16.0/20 is directly connected, FastEthernet0/0
R       172.16.0.0/16 [120/1] via 192.168.0.5, 00:00:10, Serial0/1
R    10.0.0.0/8 [120/1] via 192.168.0.0, 00:00:15, Serial0/0
     192.168.0.0/24 is variably subnetted, 7 subnets, 2 masks
C       192.168.0.0/32 is directly connected, Serial0/0
C       192.168.0.0/31 is directly connected, Serial0/0
R       192.168.0.2/32 [120/1] via 192.168.0.5, 00:00:10, Serial0/1
R       192.168.0.2/31 [120/1] via 192.168.0.5, 00:00:10, Serial0/1
                       [120/1] via 192.168.0.0, 00:00:15, Serial0/0
R       192.168.0.3/32 [120/1] via 192.168.0.0, 00:00:15, Serial0/0
C       192.168.0.4/31 is directly connected, Serial0/1
C       192.168.0.5/32 is directly connected, Serial0/1
S*   0.0.0.0/0 [1/0] via 10.0.0.254

#####################--R3--#####################
R3#sh ip route
Gateway of last resort is 10.0.0.254 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.32.0/20 is directly connected, FastEthernet0/0
R       172.16.0.0/16 [120/1] via 192.168.0.4, 00:00:25, Serial0/0
R    10.0.0.0/8 [120/1] via 192.168.0.2, 00:00:27, Serial0/1
     192.168.0.0/24 is variably subnetted, 7 subnets, 2 masks
R       192.168.0.0/32 [120/1] via 192.168.0.4, 00:00:25, Serial0/0
R       192.168.0.0/31 [120/1] via 192.168.0.4, 00:00:25, Serial0/0
                       [120/1] via 192.168.0.2, 00:00:27, Serial0/1
R       192.168.0.1/32 [120/1] via 192.168.0.2, 00:00:27, Serial0/1
C       192.168.0.2/32 is directly connected, Serial0/1
C       192.168.0.2/31 is directly connected, Serial0/1
C       192.168.0.4/32 is directly connected, Serial0/0
C       192.168.0.4/31 is directly connected, Serial0/0
S*   0.0.0.0/0 [1/0] via 10.0.0.254

After the unplug (waited 5 min)

Code:
TopSwitch#traceroute 172.16.32.2

Type escape sequence to abort.
Tracing the route to 172.16.32.2

  1 172.16.31.254 4 msec 0 msec 0 msec
  2  *  *  *
  3 192.168.0.1 4 msec 4 msec 4 msec
  4  *  *  *
  5 192.168.0.1 4 msec 4 msec 4 msec
  6  *  *  *
  7 192.168.0.1 4 msec 4 msec 4 msec
  8  *  *  *
  9 192.168.0.1 8 msec 8 msec 16 msec
 10  *  *  *
 11 192.168.0.1 8 msec 8 msec 8 msec
 12  *  *  *
 13 192.168.0.1 8 msec 8 msec 8 msec
 14  *  *  *
 15 192.168.0.1 12 msec 12 msec 12 msec
 16  *  *  *
 17 192.168.0.1 12 msec 12 msec 12 msec
 18  *  *  *
 19 192.168.0.1 12 msec 12 msec 12 msec
 20  *  *  *
 21 192.168.0.1 16 msec 16 msec 16 msec
 22  *  *  *
 23 192.168.0.1 16 msec 16 msec 16 msec
 24  *  *  *
 25 192.168.0.1 16 msec 16 msec 16 msec
 26  *  *  *
 27 192.168.0.1 20 msec 20 msec 20 msec
 28  *  *  *
 29 192.168.0.1 20 msec 20 msec 24 msec
 30  *  *  *

#####################--R1--#####################
R1#sh ip route
Gateway of last resort is 10.0.0.1 to network 0.0.0.0

R    172.16.0.0/16 [120/1] via 192.168.0.3, 00:00:07, Serial0/1
                   [120/1] via 192.168.0.1, 00:00:24, Serial0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/1
     192.168.0.0/24 is variably subnetted, 4 subnets, 2 masks
C       192.168.0.0/31 is directly connected, Serial0/0
C       192.168.0.1/32 is directly connected, Serial0/0
C       192.168.0.2/31 is directly connected, Serial0/1
C       192.168.0.3/32 is directly connected, Serial0/1
S*   0.0.0.0/0 [1/0] via 10.0.0.1

#####################--R2--#####################
R2#sh ip route
Gateway of last resort is 10.0.0.254 to network 0.0.0.0

     172.16.0.0/20 is subnetted, 1 subnets
C       172.16.16.0 is directly connected, FastEthernet0/0
R    10.0.0.0/8 [120/1] via 192.168.0.0, 00:00:07, Serial0/0
     192.168.0.0/24 is variably subnetted, 4 subnets, 2 masks
C       192.168.0.0/32 is directly connected, Serial0/0
C       192.168.0.0/31 is directly connected, Serial0/0
R       192.168.0.2/31 [120/1] via 192.168.0.0, 00:00:07, Serial0/0
R       192.168.0.3/32 [120/1] via 192.168.0.0, 00:00:07, Serial0/0
S*   0.0.0.0/0 [1/0] via 10.0.0.254

#####################--R3--#####################
R3#sh ip route
Gateway of last resort is 10.0.0.254 to network 0.0.0.0

     172.16.0.0/20 is subnetted, 1 subnets
C       172.16.32.0 is directly connected, FastEthernet0/0
R    10.0.0.0/8 [120/1] via 192.168.0.2, 00:00:17, Serial0/1
     192.168.0.0/24 is variably subnetted, 4 subnets, 2 masks
R       192.168.0.0/31 [120/1] via 192.168.0.2, 00:00:17, Serial0/1
R       192.168.0.1/32 [120/1] via 192.168.0.2, 00:00:17, Serial0/1
C       192.168.0.2/32 is directly connected, Serial0/1
C       192.168.0.2/31 is directly connected, Serial0/1
S*   0.0.0.0/0 [1/0] via 10.0.0.254

R3 can ping to R2's active interface (192.168.0.1) still.
However I cannot ping from R3's 172.16.47.254 -> R2's 172.16.31.254

So I'm assuming there is a problem with the router rip setup for the 172.16.0.0 network? I'm not sure how rip should tell the diff in the routes for two networks at either end that share the same class since the network command is 'network 172.16.0.0' for both routers...
 
Can you paste configs in code box for each router? That will help. You are probably not correctly advertising a network on one of your routers.

Rip sucks ass plain and simple. It is a loop causing monstrosity and v1 and v2 both suck ass. I am surprised that you would even have detailed configuration questions on the CCENT test. CCNA you have like 1 or 2 but it mostly focuses on real routing protocol usage such as EIGRP/OSPF and stuff.

Have you read the blog over at http://ciscoiseasy.blogspot.com/
 
Correct me if I'm wrong, but don't you still have to manually add "ip classless" on RIP v2 for all the routers? Its been awhile lol. Damn perishable skills.
 
Can you paste configs in code box for each router? That will help. You are probably not correctly advertising a network on one of your routers.

Rip sucks ass plain and simple. It is a loop causing monstrosity and v1 and v2 both suck ass. I am surprised that you would even have detailed configuration questions on the CCENT test. CCNA you have like 1 or 2 but it mostly focuses on real routing protocol usage such as EIGRP/OSPF and stuff.

Have you read the blog over at http://ciscoiseasy.blogspot.com/

I'll take a look at that read another night. Tired of banging my head on this issue :-/
I've got the configs in CODE in the first post, just one big CODE with all the configs.
Since the networks are 172.16.16.0/20 and 172.16.32.0/20 in rip you just enter in 'network 172.16.0.0' and it's suppose to cover them all...not sure how it magically figures out which subnet is where but I guess that's the fun. I tried entering in 172.16.16.0 but it just changed it to 172.16.0.0 automatically...sigh.

edit:
Just loaded that blog. Why pink border???, Oh Whyyyyyyy?????
 
Hrrmm... do you have a bad serial cable on your alternate pathway?
 
Last edited:
I understand how your putting it however doesn't rip indicate that a link is down so it would re-route the data through the live path? RIP should be the splitter with a control valve, right?
 
Hrrmm... do you have a bad serial cable on your alternate pathway?

I can pass traffic through all serial cables no problem.
from R1 I can ping to BottomSwitch through either serial interfaces so assmuing that the cables are working properly.

However, tracing with all the cables plugged in I've got something weird going on.

Code:
R1#traceroute
Protocol [ip]:
Target IP address: 172.16.47.254
Source address: 192.168.0.2
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 172.16.47.254

  1 192.168.0.3 16 msec
    192.168.0.1 12 msec *
R1#traceroute
Protocol [ip]:
Target IP address: 172.16.47.254
Source address: 192.168.0.0
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 172.16.47.254

  1 192.168.0.1 4 msec
    192.168.0.3 12 msec
    192.168.0.1 4 msec

Why would it jump from R2 -> R3 -> R2?
 
I hate to be cryptic, but I really want you to figure this out. Try the command "show ip rip database". This will lead you in the right direction.
 
I hate to be cryptic, but I really want you to figure this out. Try the command "show ip rip database". This will lead you in the right direction.

So applied the 'no auto-summary' under the router rip config and that has fixed the problem. I don't really understand why it would need that command. While I was looking through all the commands it looked like R1 wasn't passing the route for 172.16.16.0 to R2 and R3 since it knew how to get there but R3 and R1 didn't other 172.16.16.0 existed. Is there a simple explanation to this?

Thanks for pointing me in the right direction, it's best to learn by figuring it out rather than getting all the answers ;)
 
Simple explanation: RIP summarizes routes by default. R1 never knew how to get to subnets 172.16.16.0/20 or 172.16.32.0/20. R1 saw those as the same network 172.16.0.0/16. Imagine a giant cloud encompassing TopSwitch and BottomSwitch. That was R1s view of the network.


Now you are going to ask, "How did R2 ever get to R3s subnet or vise-versa without autosummarization?".

Any router routes based on the longest network-mask match. R2 understands classless routing and therefor understands more than just /8 /16 /24 subnet masks. You can turn classless routing off using "no ip classless". R2 knows that 172.16.32.0/20 is not directly connected, it checked by doing things that are a little more advanced than CCENT, so it goes to the next longest network-mask 172.16.0.0/16. Now we get into the routing protocol RIP. Why did the route out of S0/1 get added to the routing table? Because it has less hops than if it went through S0/0 to R1.

Read about Classfull networks (A, B, C) since that is what you were using in this example. This document has tips on subnetting too. I know this is annoying, but here is another guide on the Cisco website. http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800a67f5.shtml
 
Simple explanation: RIP summarizes routes by default. R1 never knew how to get to subnets 172.16.16.0/20 or 172.16.32.0/20. R1 saw those as the same network 172.16.0.0/16. Imagine a giant cloud encompassing TopSwitch and BottomSwitch. That was R1s view of the network.


Now you are going to ask, "How did R2 ever get to R3s subnet or vise-versa without autosummarization?".

Any router routes based on the longest network-mask match. R2 understands classless routing and therefor understands more than just /8 /16 /24 subnet masks. You can turn classless routing off using "no ip classless". R2 knows that 172.16.32.0/20 is not directly connected, it checked by doing things that are a little more advanced than CCENT, so it goes to the next longest network-mask 172.16.0.0/16. Now we get into the routing protocol RIP. Why did the route out of S0/1 get added to the routing table? Because it has less hops than if it went through S0/0 to R1.

Read about Classfull networks (A, B, C) since that is what you were using in this example. This document has tips on subnetting too. I know this is annoying, but here is another guide on the Cisco website. http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800a67f5.shtml

Hey, thanks for the help and the push to find the answer. Annoying as it is there is soo much material out on the internet it's ridiculous...Now if only there were more free practice tests I would be good to go.
 
I was going to tell you turn off Auto-Summary with this very reply but reading north of here I see that you did that.

Bravo.

I NEVER use auto-summary even on EIGRP / Cisco should delete that from the next IOS update.
 
Back
Top