Can't take ownership of a folder?

ep3w

Gawd
Joined
Apr 4, 2008
Messages
646
I've got a folder in windows 8 that I can't get access to. When I right click, i can't see the size, contents, security permission anything. When I go to the advanced security settings I get this. Any idea how to take ownership of this thing? I've got no read or write access to it and can't change the security settings since i'm not owner. Thanks.



I've also tried the "replace all child object permissions" from the parent folder with no luck. It gets to the folder in question and says access denied.
 
Last edited:

pxc

Extremely [H]
Joined
Oct 22, 2000
Messages
33,064
You can try this from an admin command prompt:

Code:
takeown /f p:\backup /r /d y

icacls p:\backup /grant administrators:F /T
 

ep3w

Gawd
Joined
Apr 4, 2008
Messages
646
You can try this from an admin command prompt:

Code:
takeown /f p:\backup /r /d y

icacls p:\backup /grant administrators:F /T

I get error access denied from takeown, even using elevated command prompt.
 

ep3w

Gawd
Joined
Apr 4, 2008
Messages
646
Use a program called Unlocker.

I just tried unlocker. When I try to move the folder it says its unable and asks if I want to do it at reboot. I say yes and it reboots, but nothing happens. No errors, nothing.

I should note that this folder is on a drive bender pool.
 

devil22

2[H]4U
Joined
Jan 1, 2003
Messages
3,837
If you have not already tried, try logging into the Administrator account and changing ownership there. And maybe try safe mode. And ignore b00nie, and his lame attempt to politicize an innocuous error which all OSes experience from time to time.
 

pxc

Extremely [H]
Joined
Oct 22, 2000
Messages
33,064
Windows is protecting the folder it uses for backup. I'd imagine the proper thing to do would be to go into the backup application and delete backups, then turn off backup service(s) and then either ignore the empty folder or try deleting it again. Deleting it doesn't seem like a good idea when I think about it.
 

ep3w

Gawd
Joined
Apr 4, 2008
Messages
646
The folder is not related to Windows backup, it's one I created. It is a local disk in a drive bender pool. I've been trying everything with an admin account also, but I'll try safe mode next.

If that doesn't work, is there a way to change permissions using a Linux live CD?
 

pxc

Extremely [H]
Joined
Oct 22, 2000
Messages
33,064
The NTFS-3G driver under Linux gives full permission to the files and folders. There is nothing in Linux to check NTFS permissions against, without first creating Win-Linux user mappings in the appropriate NTFS-3G config file.

Windows is locking that folder down tight like it does with several other system folders. There's nothing particularly special about it otherwise. You could go to a Windows XP system, change owner/permissions and nuke the folder if you wanted.
 

devil22

2[H]4U
Joined
Jan 1, 2003
Messages
3,837
Booting off your install media and pressing shift-F10 once it loads, will give you a cmd.exe prompt that should have full access that you can use to try to delete it/change perms (with takeown and icacls) as well, without having to download and burn another disc.
 

therat

Limp Gawd
Joined
May 18, 2011
Messages
157
Download this file http://www.mediafire.com/?736373d4uv2hg26 It's an rar archive and contains 2 registry hacks to fix your problem.

One is InstallTakeOwnership.reg and the other is RemoveTakeOwnership.reg

The first file will install a new tab in windows explorer called "Take Ownership". It works on files and folders.

Just navigate to the folder in question and right click and on the context menu click on "Take Ownership". You will then be able to do whatever you want with that folder.

Double click on the .reg file to install it and reboot.

It works perfectly in both windows 7 and 8. I use it all the time here.

You can remove it if you choose by running the second reg file.

cheers
 

rasczak

n00b
Joined
Mar 11, 2005
Messages
10
start > run
type gpedit.msc

Computer Configuration > Windows Settings > Security Settings > Local Policies > User Rights Assignments > Backup Files and Directories

Ensure that your account has this right.
 
Top