Cant get Samba to work on Fedora Core 4

skaven

n00b
Joined
Aug 17, 2004
Messages
33
I just did an installation of Fedora Core 4 on my home computer. I figured out how to mount my NTFS partitions from another drive and get my MP3 collection moved over to my linux drive. I have since been battling with Samba in an attempt to get the files shared on my home network. Both of them reside behind the router/firewall and have static IP addresses. I have the firewall disabled on the Linux box, so I don't think that could be the problem. I have read a bunch of howtos and I have tried many samba config files. I can't figure out where I'm going wrong. Below is my current smb.conf file (parsed by testparm):


[global]
workgroup = HOOD
server string = Dionysus
username map = /etc/samba/smbusers
log file = /var/log/samba/%m.log
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = /etc/printcap
dns proxy = No
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
cups options = raw

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[data]
comment = Media Files
path = /data
read only = No
guest ok = Yes

I can see the samba server from my XP box. I have duplicated the main username on the linux box that I use in XP - same password and everything. I have made sure to add the linux users to the samba config and set the samba password. First I did this all through the command prompt, then I tried using the GUI. Both with the same result. When I double click on the server in the Network browser in XP I get the following error:

\\Dionysus is not accessible. You may not have permission to use this network resource. Contact the administrator....

The network path was not found.

I made sure that the data folder is universally writeable and readable in Linux. I'm stumped! Can anybody give me some advice?!
 

HHunt

Supreme [H]ardness
Joined
Apr 12, 2001
Messages
6,063
Are both nmbd and smbd running? What happens if you try the IP address instead of the server name?
 

skaven

n00b
Joined
Aug 17, 2004
Messages
33
Both are running, I don't think I'd be able to see the samba server from XP if they weren't?

Where should I try the server IP instead of the name? In the smb.conf file?

I also forgot to mention that I created a user in Linux called "files" and added it to the samba users and passwords. Just in case I needed a username different than the one I use in XP.

Thanks.
 

skaven

n00b
Joined
Aug 17, 2004
Messages
33
Just tried all of the following and none of it worked.

I set the samba passwords using smbpasswd. I have tried creating a windows username to match the linux/samba username and password, didn't work. I have tried using the IP address of the server within the XP network browser, and it didn't work. I tried the IP address of the server in the smb.conf file and that didn't work either. I used the GUI to create the smb.conf file with the same results. Where am I going wrong?
 

Bullitt

2[H]4U
Joined
Sep 28, 2004
Messages
2,845
in your smb.conf

Code:
debug level = 7
or so and tail the samba logs to see whats really happening
 

compuguru

n00b
Joined
Jun 29, 2004
Messages
43
By firewall, do you mean seLinux or iptables?
cause seLinux is not a firewall... you need to open up the port on iptables..

(if you did disable iptables; disregard this message)

- Jay
 

Roach

Limp Gawd
Joined
Apr 30, 2003
Messages
467
Try adding this to the Global settings...

encrypt passwords = yes
passdb backend = guest

and possibly

security = share
 

skaven

n00b
Joined
Aug 17, 2004
Messages
33
I disabled both seLinux and the Firewall checkbox during linux install. I figured I'd set up the firewall as needed in the future. I assume that means IPChains is off?

I'll try adding the other stuff when I get home. Thanks for the tips!
 

compuguru

n00b
Joined
Jun 29, 2004
Messages
43
skaven said:
I assume that means IPChains is off?

Well,... to be certain try this in the shell as root:
$service iptables stop

and then do
$service smb restart

if it smb works after that, you need to just add a rule to allow the ports through iptables...

- Jay

edit: grammar
 
Top