Beware of XFX RX 580 GTS XXX Edition

Discussion in 'Video Cards' started by DavidSar, Dec 27, 2018.

  1. DavidSar

    DavidSar n00b

    Messages:
    17
    Joined:
    Jan 27, 2010
    On November 26th, I bought an XFX Radeon RX 580 GTS XXX Edition 8GB (RX-580P8DFD6) from Amazon. The card was on sale for a special price of $189.

    After I installed the card and plugged in the monitor (ASUS VG248QE) via DisplayPort, it started buzzing, despite the fact the PC was completely cut of power.

    Then the entire PC began to misbehave (random "CPU overclocking failed" errors during POST, PC automatically powered up after shutdown).

    Before the XFX RX 580, I was using GTX 970, everything was perfectly fine. I'm using UPS, all devices are grounded. PSU (Seasonic S12G-750) in a perfect condition.

    I tried different DP cable, different monitor, different hardware, different outlet without UPS, but the buzzing at S5 never stopped. Therefore, I contacted Amazon and requested a replacement.

    Clipboard02.jpg

    I received the replacement before I sent the card back. It was brand new, in a sealed box. And guess what... same problem, and even worse! The case fans keep spinning when the PC is off and power cable completely disconnected.

    It appears the card is channeling voltage from the monitor to the PSU +12v rail. The issue is limited to DisplayPort. DVI and HDMI work fine.

    Don't believe me? Watch for yourselves.

    1st DP cable (came bundled with a monitor)



    2nd DP cable (purchased recently)



    Photo of both DP cables:

    20181227_153931.jpg

    Both DP and DVI outputs were damaged while making this video. HDMI still works.

    Probably a bad batch of cards. If someone has a contact in XFX, please let them know about it.
     
    Ranulfo and FlawleZ like this.
  2. Nolan7689

    Nolan7689 [H]ard|Gawd

    Messages:
    1,206
    Joined:
    Jun 5, 2015
    XFXSupport

    There’s a contact of sorts.

    Pretty crazy issue
     
  3. iwhocorrupts

    iwhocorrupts Limp Gawd

    Messages:
    162
    Joined:
    Dec 30, 2012
    15 years building PCs - this is one of the most bizarre things I've ever seen.
     
  4. {NG}Fidel

    {NG}Fidel [H]ardness Supreme

    Messages:
    5,909
    Joined:
    Jan 17, 2005
    Damn I'm getting one back in rma for a friend... This is worrisome.
     
  5. Morphes

    Morphes 2[H]4U

    Messages:
    4,008
    Joined:
    Jul 16, 2001
    Thats crazy, and when you unplug the DP cable the fans go off? Have you tried with any DP adapters to see if it has the same issue with or without?
     
  6. Araxie

    Araxie [H]ardness Supreme

    Messages:
    6,351
    Joined:
    Feb 11, 2013
    this is the reason why only certified displayport cables should be used, as uncertified ones have the 20th pin active, transferring power from the monitor to the GPU and from the GPU to the motherboard..
     
    Armenius likes this.
  7. Auer

    Auer Limp Gawd

    Messages:
    340
    Joined:
    Nov 2, 2018
    Considering the amount of XFX 580's out there I wonder why we havent heard more of this.

    Or is it really a cable issue as posted above?

    A
     
  8. LigTasm

    LigTasm [H]ardness Supreme

    Messages:
    4,908
    Joined:
    Jul 29, 2011
    I also bought one of these, mine ran at 100% fan speed all the time and the display blacked out every 2-3 seconds. It was installed for about 20-30 minutes before I put it back in the box and sent it back .
     
  9. Auer

    Auer Limp Gawd

    Messages:
    340
    Joined:
    Nov 2, 2018
    Display Port or HDMI?

    A
     
  10. LigTasm

    LigTasm [H]ardness Supreme

    Messages:
    4,908
    Joined:
    Jul 29, 2011

    Both.
     
  11. ManofGod

    ManofGod [H]ardForum Junkie

    Messages:
    9,984
    Joined:
    Oct 4, 2007
    For anyone who is reading this thread, insofar as the recent XFX RX580 series is concerned, stay far, far away from them. I went through 3 from Best Buy and they all had issues. (Not doing the clocks out of the box, black screen flashing, corrupted bios screen and the like.) Instead, pick up the Powercolor Red Devil RX580.

    I bought this one from Microcenter: https://www.newegg.com/Product/Product.aspx?Item=N82E16814131713 and it has a 6 and 8 pin power connector.
     
    Armenius and LigTasm like this.
  12. Auer

    Auer Limp Gawd

    Messages:
    340
    Joined:
    Nov 2, 2018
  13. ManofGod

    ManofGod [H]ardForum Junkie

    Messages:
    9,984
    Joined:
    Oct 4, 2007
  14. Auer

    Auer Limp Gawd

    Messages:
    340
    Joined:
    Nov 2, 2018
    OC and Stock Time Spy

    A
     

    Attached Files:

  15. Auer

    Auer Limp Gawd

    Messages:
    340
    Joined:
    Nov 2, 2018
    Firestrike OC

    A

    Screenshot_2018-12-30-10-56-23.png
     
    {NG}Fidel likes this.
  16. DavidSar

    DavidSar n00b

    Messages:
    17
    Joined:
    Jan 27, 2010
    I tried 2 DP cables, one came bundled with some monitor, the other purchased separately and supposed to be DP 1.4 certified.

    Possibly a bad batch, I've seen a few reviews on Amazon mentioning 'electric sparks' and such.

    And yes, it is the same card you linked to. If you overclocking, try to undervolt to reach higher clock, I noticed the card is being overvolt by default.

    Yes... also doesn't happen with DVI. I tried some adapters, made a minor improvement, but I sent the card back already.
     
    Auer likes this.
  17. ManofGod

    ManofGod [H]ardForum Junkie

    Messages:
    9,984
    Joined:
    Oct 4, 2007
    Thanks, you managed to get a good one. The one I had was supposed to get 1405 out of the box and did not. Also, I would get black screen flashes from all 3 cards that I tried.
     
    Auer likes this.
  18. Auer

    Auer Limp Gawd

    Messages:
    340
    Joined:
    Nov 2, 2018
    Hopefully there are a lot more like mine out there.

    It sucks to get faulty products no matter what it is.

    But based on my own limited experience I would buy XFX again.

    A
     
  19. ManofGod

    ManofGod [H]ardForum Junkie

    Messages:
    9,984
    Joined:
    Oct 4, 2007
    Sorry for hijacking this thread but since my issue appears to be an RX 580 issue, I will ask here: Anyone have stuck 3d clocks after exiting a game? (Not memory, just gpu.) For instance, with Gears of War 4 and how did you fix it? Thanks.

    I have an XFX RX 570 RS 8GB card that I bought in September and it runs without issues. It just seems to be an across the board issue with recently released XFX RX 580 cards, which is why I cannot recommend them.
     
  20. DavidSar

    DavidSar n00b

    Messages:
    17
    Joined:
    Jan 27, 2010
    Latest drivers are somehow buggy. Its better to stick to previous drivers from 2-3 months ago.
     
  21. ManofGod

    ManofGod [H]ardForum Junkie

    Messages:
    9,984
    Joined:
    Oct 4, 2007
    So, 18.9 or 18.10? Thanks.
     
  22. DavidSar

    DavidSar n00b

    Messages:
    17
    Joined:
    Jan 27, 2010
    Neither. Drivers from September solve the 100% GPU usage issue.
     
  23. ManofGod

    ManofGod [H]ardForum Junkie

    Messages:
    9,984
    Joined:
    Oct 4, 2007
    18.9 then it is, thanks. (Those are the September drivers. :) )
     
  24. Armenius

    Armenius I Drive Myself to the [H]ospital

    Messages:
    16,538
    Joined:
    Jan 28, 2014
    If it's not in this DB then it isn't certified. Manufacturers spoof the DP logo and stamp all the time.

    https://www.displayport.org/product-category/cables-adaptors/
     
    Auer likes this.
  25. ManofGod

    ManofGod [H]ardForum Junkie

    Messages:
    9,984
    Joined:
    Oct 4, 2007
    I literally could not use anything past 18.3.4 or the GPU clocks lock at the 3d clocks of the card after exiting a game.
     
    DavidSar likes this.