Backup ADSL on Cisco Router?

DlStreamnet

Limp Gawd
Joined
Mar 10, 2005
Messages
359
Hi guys

I have a Cisco 861 which connects to a BTnet connection using FA0

I would like to connect FA1 to an existing ADSL router which will have no security on it at all, and simply forward all ports to the Cisco (technically a DMZ?)

Then when the 861 fails I would like to make the ADSL router take over default gateway functionality.

How would I configure this?

I'm thinking a static route with a higher AD?

Or if the modem supports it, put it in modem only mode and let the Cisco handle authentication?

The problem is they have static nat port forwards for internal web servers, how would it know to change to the other connection if the BTnet failed?
 

DlStreamnet

Limp Gawd
Joined
Mar 10, 2005
Messages
359
For anyone interested, this is how I've configured it. It only works when the BT interface goes down, i.e. router failure or billing query however. I may implement IP SLA to track the default gateway route.

Code:
Building configuration...

Current configuration : 1670 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 12.0.0.2 255.255.255.0
 ip nat outside
 duplex auto
 speed auto
!
interface Ethernet1/0
 ip address 13.0.0.2 255.255.255.0
 ip nat outside
 half-duplex
!
interface Ethernet1/1
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 half-duplex
!
interface Ethernet1/2
 no ip address
 ip nat inside
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 ip nat inside
 shutdown
 half-duplex
!
ip nat pool 12net 12.0.0.2 12.0.0.2 netmask 255.255.255.252
ip nat pool 13net 13.0.0.2 13.0.0.2 netmask 255.255.255.252
ip nat inside source static tcp 192.168.1.1 21 interface FastEthernet0/0 21
ip nat inside source route-map 12net-map pool 12net overload
ip nat inside source route-map 13net-map pool 13net overload
ip nat inside source static tcp 192.168.1.10 80 12.0.0.2 80 extendable
ip nat inside source static tcp 192.168.1.10 80 13.0.0.2 80 extendable
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 0.0.0.0 0.0.0.0 Ethernet1/0 10
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
route-map 13net-map permit 10
 match ip address 1
 match interface Ethernet1/0
!
route-map 12net-map permit 10
 match ip address 1
 match interface FastEthernet0/0
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
 

/usr/home

Supreme [H]ardness
Joined
Mar 18, 2008
Messages
6,160
Yes it won't auto failover because for all it knows the gateway is still getting the packets.
 

DlStreamnet

Limp Gawd
Joined
Mar 10, 2005
Messages
359
Yeah, and apparently the 861 doesn't support track - so this is as good as it gets.
 
Top