asus Prime B450-plus on a Ryzen 5 3600X

p05ta1

Limp Gawd
Joined
Mar 19, 2001
Messages
329
I am sure you guessed I am stuck.
Got the system together and everything turn on but no signal and no bios.
Looks like I am in waiting for a boot recovery kit form AMD.
I submitted for a ticket on 4/4 will see how long it will take.

anyone know how long this will take ?
 

Zepher

[H]ipster Replacement
Joined
Sep 29, 2001
Messages
17,479
is that due to the BIOS not up to date for the 3600X?
 

p05ta1

Limp Gawd
Joined
Mar 19, 2001
Messages
329
yes , my dads old pc was a intel i3.
so he bought that since the motherboard came with 16 ddr 4 ram deal on amazon.
Those all need a bios to see that cpu.
 

p05ta1

Limp Gawd
Joined
Mar 19, 2001
Messages
329
ticket got moved to next level. I had to submit receipt and pictures of cpu and mainboard.
4/6 I emailed them all info .
 

p05ta1

Limp Gawd
Joined
Mar 19, 2001
Messages
329
YD200GC6FBBOX was shipped on 4/7.
still waiting on FedeX to deliver it.
AMD was very quick on this action for me, only thing that bugs me so far is they ship it but no tracking info is in email so I have to keep guessing when it will show up.
This Cova19 stuff is really screwing up my amazon orders.
 

p05ta1

Limp Gawd
Joined
Mar 19, 2001
Messages
329
well got amd bootkit. installed no issues, booted into bios and flashed to latest bios.
rebooted into bios and checked all setting. everything was seen in bios so i was good, turned off and swapped in the 3600X.

Reboot i got just fans and no fan on his RTX2060. Hard reset i get just fans.
Looks like the corsair 550watt refurb power supply is not cutting it. it must be just enought to power the Athalon am4 boot kit but as soon as i drop the 3600x in it goes over the top.
I got a 750 watt NEW Corsair CX series on way.
 

p05ta1

Limp Gawd
Joined
Mar 19, 2001
Messages
329
Finally got it all built out!
Found out the EVGA RTX2060 is crap!
yep, i still get no boot with the evga rtx 2060 after Bios flash, new power supply.
But i toss in a GTX 970 or MY RTX 2070 thing boot fine and windows is activatied,
guess i can move this now to EVGA warranty issue.
 

kirbyrj

Fully [H]
Joined
Feb 1, 2005
Messages
26,113
At least you know what you have to do to get it working. Glad you got the board/CPU sorted out.
 

p05ta1

Limp Gawd
Joined
Mar 19, 2001
Messages
329
Evga was great, called them on phone and explained issue with RTX2060 card and new build.
They did ask a few questions i did explain again, I know they are trying to cover all bases.
Mailed bad card saturday priority mail and when they get new one is on way!
 

p05ta1

Limp Gawd
Joined
Mar 19, 2001
Messages
329
Closing out this post.
The PC is awesome!
Evga RTX 2060
amd Ryzen 3600X
asus b450 plus
corsair 750 watt ps
corsair temper glass case.
IMG_20200509_123033.jpg
IMG_20200509_212201.jpg
 

ThreeDee

[H]F Junkie
Joined
Sep 5, 2001
Messages
10,802
Good things come to those that wait they say ... congrats!
I run the ASUS B350 Prime in my wife's rig with a 3400g and 4 x 8GB 3200mhz .. It's been super stable and using the built in Vega graphics in the 3400g, I'm utilizing all 3 video out's to run 3 monitors without issue.
 
Top