Asus AI suite 2 for Z77 boards

Imitation

2[H]4U
Joined
Jun 18, 2004
Messages
2,536
So apparently a win10 update a few months ago borked the AI suite 2 on these older boards like my maximus V gene. I've looked around and haven't found much info on if asus is going to fix version 2 of the software, they already fixed version 3, but it won't install saying I have the wrong board model.

Being able to set fan curves and look at all the other details within the suite was really handy but doesn't work anymore. I tried speedfan as well and it wouldn't work, I think because the bios can control the fans, speedfan cannot, tho the bios options are pretty poor compared to the AI suite.

Anyone else have it working? Or a good replacement?
 

pendragon1

Extremely [H]
Joined
Oct 7, 2000
Messages
41,172
does speedfan see the fans? if it does you have to set the fans to voltage controlled in the bios. the z97 system I have here is like that. other than that maybe email asus and say WTF?!
 

Imitation

2[H]4U
Joined
Jun 18, 2004
Messages
2,536
I'll try that out. Reading thru the ROG forums, there doesn't seem to be much resolution there, some ppl have posted emails saying the mobo is too old, there won't be an update.
 

Imitation

2[H]4U
Joined
Jun 18, 2004
Messages
2,536
This actually worked. Disabling the bios control let speedfan take over. That was super helpful, thanks. I'll miss some of the other utilities but the fan speeds were what i was looking to fix the most!
 

pendragon1

Extremely [H]
Joined
Oct 7, 2000
Messages
41,172
I use speedfan and afterburner to monitor all the other things. glad that worked for ya :)
 
Top