Artifacts after flashing to original bios?

MattQC

Limp Gawd
Joined
Jun 18, 2008
Messages
141
I bought a Galaxy 670 GTXGC 4GB from a member here. It came with a modded bios and when I try to flash the original bios (or any other bios) there are multicolors flickering artifacts like this all over the screen. Furthermore, the resolution stays at 800x600 in windows even when uninstalling/reinstalling drivers.

Flashing back to the modded bios fix everything. I want to go back to original bios because it is needed for waranty and the card started acting weird. Any idea what could cause that?

Specs:
Phenom X4 955
Asus M5A785TD-V EVO
4GB DDR3 667
OCZ 600W gamexstream

Thanks.
 

xorbe

Supreme [H]ardness
Joined
Sep 26, 2008
Messages
6,028
After flashing, did you try turning off the PC, and yanking the power cable out of the PSU for about 10-15 seconds? Also, try re-installing the driver after the bios flash. Check that MSI AB or EVGA Precision isn't messing with the clocks.
 

MattQC

Limp Gawd
Joined
Jun 18, 2008
Messages
141
I tried all suggestions and nothing worked. No bios switch but according to the specs, the card has a dual bios. They say that if the card cannot boot due to a bad bios it will flash the original one.

When I open the bios side by side with Kepler bios tweaker they both have the same memory speed.
 

xorbe

Supreme [H]ardness
Joined
Sep 26, 2008
Messages
6,028
A 670 isn't usually 4GB. Where did you get the "original" bios?
 

Shodin10k

Gawd
Joined
Mar 13, 2005
Messages
618
Ive had this issue before with my GTX 570.

Plain and simple, I was using the wrong bios when flashing (i.e. different model gtx 570, like an xfx be vs a non be bios)
 

Kardonxt

2[H]4U
Joined
Apr 13, 2009
Messages
3,529
The other possibility is that the seller was running a modded bios to increase the default voltages and stop the artifacting / other issues. Puting the bios back to stock could remove his band-aid.

If this is the case then put the stock bios in and send it out for repair as it should all be covered. You need to be 100% sure it's the right bios or you could void your warranty.
 

MattQC

Limp Gawd
Joined
Jun 18, 2008
Messages
141
Well as far as I know the seller didnt have any problem and im trying to install the correct bios.
 
Top