AMD's ATI Catalyst 10.2 and 10.3 Preview @ [H]

e-geek

Gawd
Joined
Oct 13, 2005
Messages
578
One thing that was weird - i express uninstalled all ati software, booted to safe mode cleaned ati display files (driver sweeper) then booted norm reinstalled rebooted and it set an eyefinity group automatically.

But bioshock 2 seems to be the game with issues as bioshock 1 runs fine same as other games.
 

bufodr_T

Supreme [H]ardness
Joined
Nov 5, 2005
Messages
5,366
During the driver install my screen went blank and I got the no signal warning. Figured no problem, the pic will come right back...

It didn't come back. AT ALL. I waited about 5 minutes and still no pic, but pandora was still playing.

Had to hold the power switch to shut down. Rebooted and still no video.. I have rebooted a few times now and STILL no video even for the initial post!

Did the new driver fry my card? Did it swap the DVI output my card uses? (Edit: it didn't swap outputs. I tested the other one.)
i feel your pain...
i did the same. uninstalled the old drivers reboot and install new drivers...reboot...now the windows logo comes up and then either gives me a gray screen of death or a blue screen of death...no problems before with 10.1. trying to do a repair os right now.
 

tannat

Limp Gawd
Joined
Aug 20, 2008
Messages
155
Because it's something people automatically judge as 'missing' when they move (like I did) from high end nvidia cards to crossfireX 5870s. It's expected functionality at this point, and it's still missing without basically getting nhancer ATI edition (ati tray tools).

I quite appreciate being able to set a profile for a game and never screwing with it again. And having the driver auto-detect and apply my settings. I thought ati understood this and was implememting a proper profile management system, a la nvidia. But that isn't the case.
You're not aware that such application profiles already do exists i catalyst?
 

dook43

2[H]4U
Joined
Sep 9, 2005
Messages
2,949
Crossfire seems to be working at 3840x1200 in dirt2... 40FPS on 5850s with 0AA and everything highest
 

JCDenton

Gawd
Joined
Jan 6, 2008
Messages
701
Well crossfire doesn't work in any games for me now (5970) with 10.2 drivers, sigh...:rolleyes:
Wow, what a joke. Looks like I'm STILL stuck with 9.12 for 5970+5870. I've never seen such incompetence in terms of drivers. Can't wait to get these cards out of my system as long as Fermi is remotely decent. ATI wasn't even all that bad in the past. I had no complaints with my X1900XTX.
 

robble

Supreme [H]ardness
Joined
Jun 6, 2004
Messages
6,499
The best advice - if it works don't mess with it. I "upgraded" to 10.2 a couple days ago and my video card has not worked AT ALL since then. I don't even get a display during POST. =(

the computer does boot however without any error beeps. I can remote into the box and see everything I should be seeing (except the catalyst control panel).

I'm actually typing this at work while remoted into my home computer.

Seems like several other people are having other problems too.
 

JCDenton

Gawd
Joined
Jan 6, 2008
Messages
701
The best advice - if it works don't mess with it. I "upgraded" to 10.2 a couple days ago and my video card has not worked AT ALL since then. I don't even get a display during POST. =(

the computer does boot however without any error beeps. I can remote into the box and see everything I should be seeing (except the catalyst control panel).

I'm actually typing this at work while remoted into my home computer.

Seems like several other people are having other problems too.
Sounds more like coincidence than drivers. I know it's stupid, but doublecheck your cables and try removing/reseating the card.
 

robble

Supreme [H]ardness
Joined
Jun 6, 2004
Messages
6,499
Sounds more like coincidence than drivers. I know it's stupid, but doublecheck your cables and try removing/reseating the card.
I don't buy the coincidence theory at all since the card had been working perfectly up until the middle of the driver install.

I have a thread going on this already so I won't clutter this one up anymore.
There is more of the story in this thread:
http://www.hardforum.com/showthread.php?t=1496382
 

Evil_SPanKY

Limp Gawd
Joined
Sep 15, 2006
Messages
318
With NVIDIA, while each SLI profile is in an .XML file, you still only receive SLI profile updates with an entire driver releases. This means like AMD, you have to wait until a new driver is released in order to receive new profiles.
Brent - Not true. Nvidia has released multiple SLI game profile updates only, between several driver releases. They have been doing this for over a year now, and are small binary updates to their XML profile file.

Its great AMD is finally getting with the times and going this route however. Their choice for game profile implemenation was idiotic at best.
 

-MikeHawk-

Limp Gawd
Joined
Oct 7, 2004
Messages
161
I installed 10.2's and serious issues. Desktop was all warblie and pixelated, Like rainbow colors. I have card in sig & 5770 ... both w/same issues. Went back to 10.1's
 

McKie

Gawd
Joined
Oct 29, 2009
Messages
552
Looks like I will be sticking with my 9.12 hotfix after reading all the issues with this driver.

I Installed the 10.1 drivers back when they became available and frames dropped in half. So I went back to 9.12 hotfix. looks like I'll stay there. for now.

Jeesh !!
 

necrophile

[H]ard|Gawd
Joined
Sep 6, 2008
Messages
1,243
Your post lacks any sense of reasoning whatsoever.

If the 9.12's work but the 10.1's didn't there is no reason not to try the 10.2's.
 

McKie

Gawd
Joined
Oct 29, 2009
Messages
552
Your post lacks any sense of reasoning whatsoever.

If the 9.12's work but the 10.1's didn't there is no reason not to try the 10.2's.
Sure there is. many reports of no real difference in crossfire eyefinity performance.
 

Blackhood

n00b
Joined
Apr 25, 2005
Messages
29
I installed 10.2's and serious issues. Desktop was all warblie and pixelated, Like rainbow colors. I have card in sig & 5770 ... both w/same issues. Went back to 10.1's
Same thing happens to me with a XFX 5750 (10.2's). Using HDMI to HDMI. If I use DVI to HDMI or DVI to DVI, no problems.

What's more weird is if I take a screen shot of the problem, it does not show up! Went back to 10.1 no problem. But need to get away from them because of the monitor sleep issue.
 

stiltner

[H]F Junkie
Joined
Mar 16, 2000
Messages
10,623
No issues here with the 10.2's on a 4890 so far. If things crop up I'll pass on the 411
 

Oldie

Mean Old Administrator
Staff member
Joined
Jan 12, 2004
Messages
21,813
I have an odd 10.2 issue on my XFX 5870. Win7 Ult x64, and I'm getting odd screen flickers and tearing on the desktop and during games. Almost like a window is trying to pop up, and then goes away. I might grab a video of it if it's still happening when I do an OS reinstall on Tuesday.

Flipped back to the 10.1's and it's issue free.
 

neokeelo

[H]ard|Gawd
Joined
Sep 9, 2002
Messages
1,649
Do 10.2 help with stability? If I overclock my card at all I get constant driver crashes. my 4890 with 9.10 worked great, never did this at all. Also any mention of them fixing refresh rates? My CRT used to do 120hz now every resolution is locked to 85hz ... :\
 

ZX81

Weaksauce
Joined
Apr 30, 2005
Messages
118
I downloaded the new drivers and the crossfire profile update.

Dumb question, but didn't see it in the thread, any guide as to how to use this feature?
I am playing MW2 right now, everything I got is running through steam.
Do they come from AMD website, steam, we set them up ourselves, or direct through CCC?
 

neokeelo

[H]ard|Gawd
Joined
Sep 9, 2002
Messages
1,649
Is it better to downgrade to the 9.12 drivers to avoid the Grey screen crashes? Will this bring back my old refresh rates and let me select them with Powerstrip again?
 

robble

Supreme [H]ardness
Joined
Jun 6, 2004
Messages
6,499
I installed a new 5850 last night and the screen came up. Reinstalled 10.2 (they weren't fully installed) and it seems to be working well. Later I'll try to put the 4870 back in to test it.
 

Eickst

[H]ard|Gawd
Joined
Aug 24, 2005
Messages
1,866
Is it better to downgrade to the 9.12 drivers to avoid the Grey screen crashes? Will this bring back my old refresh rates and let me select them with Powerstrip again?
You know, I finally downgraded to 9.12, I have a single card anyway so these new drivers do not do much for me anyway.

I haven't had any issues or GSODs since I installed 9.12 yesterday morning.....knock on wood
 

yacoub35

Gawd
Joined
Apr 25, 2007
Messages
729
I must say I have been very impressed by ATI/AMD the last 5 months, hope the keep up the good work.
I'm not impressed. It's the first time I've had a GPU in several years that's had buggy, problematic drivers. Then again, it's also my first ATI card in those years.
But I blame NVidia for not being able to put out a DX11 card of merit. It's their fault I bought ATI. I can't blame ATI for still being incompetent, I expected no less despite all the people claiming how their driver quality and CCC have improved (and clearly they haven't). It's the same as it was several years ago when I last owned an ATI GPU. Frustrating little annoyances everywhere. I never had a problem with NVidia's drivers. They just simply worked. All the time. Every game. Every desktop situation. None of the hitching and freezing video in Flash or WMP or MPC. No issues coming out of sleep. No crashes in games. I already miss that stability and reliability and maybe in a few months if their new cards actually perform well and have a good price I'll be able to switch back.
 

hedron

Limp Gawd
Joined
Apr 24, 2008
Messages
495
Sooo..... When are we going to get a stability update? Always adding features and never fixing bugs. Added features aren't very impressive when your games keep crashing... I don't get it, their drivers are so buggy, yet they work on adding useless features like bezel correction? I wouldn't even use that if I had a 3 monitor setup. How many people have 3 monitor setups to begin with? Yet my games are crashing and I can't even install Linux because 3D doesn't work. There's a feature you could work on AMD, 3D for Linux. Wow! Imagine that, a 3D graphics card that renders 3D graphics?! I really have no idea what possessed me to go AMD with my current rig. I've really had enough. I'm not sure I'll ever buy AMD again.
 
Last edited:

alucard_x

Weaksauce
Joined
Aug 26, 2004
Messages
103
I'm not impressed. It's the first time I've had a GPU in several years that's had buggy, problematic drivers. Then again, it's also my first ATI card in those years.
But I blame NVidia for not being able to put out a DX11 card of merit. It's their fault I bought ATI. I can't blame ATI for still being incompetent, I expected no less despite all the people claiming how their driver quality and CCC have improved (and clearly they haven't). It's the same as it was several years ago when I last owned an ATI GPU. Frustrating little annoyances everywhere. I never had a problem with NVidia's drivers. They just simply worked. All the time. Every game. Every desktop situation. None of the hitching and freezing video in Flash or WMP or MPC. No issues coming out of sleep. No crashes in games. I already miss that stability and reliability and maybe in a few months if their new cards actually perform well and have a good price I'll be able to switch back.
thats what i was afraid of after moving from a 8800GTS to an ATI5770. 10.2 has been OK for me so far, though i've only been playing bad company 2.. i'm hoping i don't have any issues. wish nV would have gotten their act together.
 

Flyinfinni

[H]ard|Gawd
Joined
Nov 24, 2009
Messages
1,300
I've not yet had an issue with an ATI driver, either with my 4870, or now with my 5750. I'll let you know about Xfire when I get my second 5750 running, but maybe theres more going on than just drivers? These are my first few ATI cards too- always Nvidia before the 4870. Not 1 driver problem yet.
I know their drivers are not perfect, but thats the nature of software and Nvidia's drivers aren't perfect either (remember- they just pulled a bunch of drivers for causing cards to overheat).
 

FocalFury

n00b
Joined
Nov 17, 2009
Messages
58
I cannot get the 10.3 demo drivers t properly install
I have uninstalled ATI CCC and done fresh restarts and then just done the 10.3 exe but once I restart after installing it it states I am using 10.2

Any ideas? would really like to get some bezel management and profile switching capabilities.

D A N N Y
 

Derangel

Fully [H]
Joined
Jan 31, 2008
Messages
18,789
I cannot get the 10.3 demo drivers t properly install
I have uninstalled ATI CCC and done fresh restarts and then just done the 10.3 exe but once I restart after installing it it states I am using 10.2

Any ideas? would really like to get some bezel management and profile switching capabilities.

D A N N Y
Have you used Driver Sweeper to completely clean the drives from your system after a reinstall?
 

Flyinfinni

[H]ard|Gawd
Joined
Nov 24, 2009
Messages
1,300
Crossfire working great on 10.3 with my 5750s! Getting a great performance increase (88% increase in my GPU score in 3dMark Vantage) and NO driver issues so far.
 

WAKASHIZuMa

Limp Gawd
Joined
Sep 23, 2009
Messages
193
I have installed the latest drivers (10.2) for my ATI Radeon 585- and while Windows 7 runs normal, when I log in and out there is a slight slowness and unresponsiveness to the screen. Granted it goes away rather quickly, but the Windows 7 effects and Aero seem to slow down for a moment or two but I never had issue on my ATI Radeon 4670

Any ideas?
 

Flyinfinni

[H]ard|Gawd
Joined
Nov 24, 2009
Messages
1,300
There was a Part 1 and part 2 article on Toms, and I think there was an update on one of them saying that ATI knew the problem and was going to work it into a driver update (I think they said the official release will be in 10.3 or 10.4) I'd have to go back and reread those articles to remember exactly, which I don't have time to do right now :-p
 
Top