AMD Radeon Software Crimson ReLive 17.3.3 Driver

Megalith

24-bit/48kHz
Staff member
Joined
Aug 20, 2006
Messages
13,003
Not to be outdone by NVIDIA, AMD has also released drivers for improving the Mass Effect: Andromeda experience. Such refinements would include a new multi GPU profile, as well as a patch for flickering textures. Now they just need to figure out how to fix autistic faces and running animations through a driver update…
 

pek

prairie dog
Joined
Nov 7, 2005
Messages
2,139
So we have to enable xfire via command line just before running the game? Doesn't this turn on xfire full time rather than when needed when the profile runs? Is this a band-aid for the not having a profile in game settings? I don't have me:a installed yet, later today when I get it.
 
Last edited:

pendragon1

Extremely [H]
Joined
Oct 7, 2000
Messages
39,798
sweet! I was gonna reinstall 17.3.2 this morning as my insider preview updated last night. now I can use these. thnx man!
 

pek

prairie dog
Joined
Nov 7, 2005
Messages
2,139
Hmmm, when I tried to load 17.3.3 on my r9 295x2, my system went to hell. Uninstalled 17.3.3, rolled back to 17.2.1, my second gpu didn't show up. fiddled around a bit (a day, actually) with different versions, I moved my gpu to the 2nd x16 pci clot, and with 17.2.1, got everything showing correctly. Not sure if 17.3.3 and my 295x2 don't get along or not, but no xfire for me on andromeda. Not that it really needed it, I think I'm almost maxed out and the game runs smooth @ 1440. With freesync on. Didn't really wan to open my case up and muck about with things, but, anything else wouldn't be [H]ard, I guess.
 

Sicario

Weaksauce
Joined
Dec 29, 2006
Messages
113
Hmmm, when I tried to load 17.3.3 on my r9 295x2, my system went to hell. Uninstalled 17.3.3, rolled back to 17.2.1, my second gpu didn't show up. fiddled around a bit (a day, actually) with different versions, I moved my gpu to the 2nd x16 pci clot, and with 17.2.1, got everything showing correctly. Not sure if 17.3.3 and my 295x2 don't get along or not, but no xfire for me on andromeda. Not that it really needed it, I think I'm almost maxed out and the game runs smooth @ 1440. With freesync on. Didn't really wan to open my case up and muck about with things, but, anything else wouldn't be [H]ard, I guess.

Same. I thought I fried one of the gpu's.
 
Top