840 EVO 250gbx4 LSI 9266 4i seems slow?

Discussion in 'SSDs & Data Storage' started by bpgt64, Feb 20, 2014.

  1. bpgt64

    bpgt64 n00b

    Messages:
    4
    Joined:
    Dec 11, 2013
    Settings used;
    Write through cache
    no read ahead
    direct write to drive

    Tried a variety of striping, I am under-provisioning the drives, and still getting sub 1.2GB/s performance on writes. I know it shouldn't necessarily be additive, but still not getting what should I think should be right...~1.5gb/s-1.8
     
  2. drescherjm

    drescherjm [H]ardForum Junkie

    Messages:
    14,475
    Joined:
    Nov 19, 2008
    Is the test at least a few GB? Also you may want to try write back.
     
  3. bpgt64

    bpgt64 n00b

    Messages:
    4
    Joined:
    Dec 11, 2013
    The test is Dxtory's benchmark, it writes a very large file to disk. ~10GBs
     
  4. bpgt64

    bpgt64 n00b

    Messages:
    4
    Joined:
    Dec 11, 2013
    And write back fixed the issue...thank you SO much. I am getting 2031mb/s
     
  5. drescherjm

    drescherjm [H]ardForum Junkie

    Messages:
    14,475
    Joined:
    Nov 19, 2008
    Write back does open a chance of some data loss since the data is buffered in the cards 1GB of cache. If you lost power with data in still the cache your array would have some corruption that is if you do not have the BBU module.

    I asked you to enable that because I thought the problem was due to too small writes. I mean when you raid0 whatever block size you are writing gets divided amongst the drives in the array. And since SSDs do not read or write small blocks at anywhere near 500MB/s you can see much lower performance then expected because all drives in the array are doing smaller writes. The cache fixes that by buffering the writes and flushing bigger blocks at a time.
     
    Last edited: Feb 20, 2014
  6. Old Hippie

    Old Hippie [H]ardness Supreme

    Messages:
    6,013
    Joined:
    Oct 31, 2005
    You won't get great performance they would be capable of without the FastPath option.;)