[5700xt] Windows10 freezes after Driver installation

Rev. Night

Limp Gawd
Joined
Mar 30, 2004
Messages
499
The error that I am having is that when I install AMD graphics drivers (20.9.1,2, or 11.2), Windows 10 will freezes. I have used AMD cards for years, but this is the first time I have ever seen this error.

I was playing Horizon Zero Dawn and it crashed, and reddit said to install all windows updates as troubleshoot. I install them (listed below), windows restarts, and when the desktop boots up again, the pc freezes. Restart PC again, turn off PC, etc., it now always freezes. In safe mode, I turn off all Startup applications in Task Manager. Restart to normal boot, and pc is fine until I see the red radeon taskbar icon load, then pc immediately crashes. So this narrows it down to the driver (20.9.2), which I have had for several weeks and no problems.

In safe mode, I use DDU to remove AMD drivers. I also use "AMD Cleanup Utility", and the report says everything was removed with no failures. Reboot to normal boot, and PC works just fine. Obviously no video drivers, but it works perfectly. More evidence that this error is related to AMD drivers. In Cmd (admin) I run the DISM and SFC commands to Repair System Registry and Files that I read in an AMD troubleshoot. SFC was fine, but DISM said it found and corrected a corrupt registry file. I delete everything from C:\AMD folder. I reboot for the hell of it.

I download new copies of 20.9.1 and 20.11.2 from AMD site. I test the 20.11.2 first. It installs just fine, pc then reboots. When it gets to desktop, the same freeze happens as soon as red tray icon shows. I perform all the same steps in previous paragraph to remove this version. I try this again with 20.9.1 and then 20.9.2. All 3 now cause my PC to freeze when desktop loads.

At this point I am out of ideas. PC clearly works just fine (I am typing this now) when AMD drivers are not installed. Yet if these drivers are so bad, why is this just happening now when I have had this card for the past year+? Could it be the windows10 updates? Sadly these are forced updates, so I couldn't uninstall most of them.

I created a ticket with AMD, but I want to see what [H] thinks too. I will post up if/when they respond.

Installed Updates:
  • Security Update for Adobe Flash Player
  • Security Update for MS Windows (KB4577266)
  • Security Update for MS Windows (KB4586781)
  • Security Update for MS Windows (KB4586864)
  • Update for MS Windows (KB4580419)
Gaming PC specs:
  • -I7-6700K (OC normally, but I made it stock for troubleshooting)
  • -AMD Radeon Sapphire Pulse 5700xt
  • -Gigabyte G170-HD3P
  • -2x8gb ram
  • -Windows 10, fully updated
 

Riptide_NVN

[H]ard|Gawd
Joined
Mar 1, 2005
Messages
1,917
I wouldn't rule out hardware failure at this point, especially if this has been running fine for quite some time and all the trouble was preceded by a crash event.
 

Rev. Night

Limp Gawd
Joined
Mar 30, 2004
Messages
499
Perhaps, but games crash all the time. I still can't play COD MW after the update they pushed 2 weeks ago. Game crashes everytime in menu, and other people are experiencing same thing
 

lopoetve

Fully [H]
Joined
Oct 11, 2001
Messages
30,777
Been having a similar issue on one of my systems, with Nvidia drivers. I did a restore point roll back, and eventually disabled windows hardware driver updates (so it doesn't search windows update for it) - something it was pulling from there was causing the problem, the driver install just triggered the conflict. Whatever it was (haven't figured it out) was the issue more than the video driver itself, but your symptoms match mine exactly (except mine is the nvidia green popping up). Might try a reinstall/disable windows driver updates/install by hand to see if it goes away.

Edit: Mine is also a Gigabyte Intel board, just newer.
 

Rev. Night

Limp Gawd
Joined
Mar 30, 2004
Messages
499
Been having a similar issue on one of my systems, with Nvidia drivers. I did a restore point roll back, and eventually disabled windows hardware driver updates (so it doesn't search windows update for it) - something it was pulling from there was causing the problem, the driver install just triggered the conflict. Whatever it was (haven't figured it out) was the issue more than the video driver itself, but your symptoms match mine exactly (except mine is the nvidia green popping up). Might try a reinstall/disable windows driver updates/install by hand to see if it goes away.

Edit: Mine is also a Gigabyte Intel board, just newer.
Interesting. I searched the internets and I found some stuff for me to try. Will do this tonight or tomorrow and report back
 
Top