5700 XT compatibility issues with old games like need for speed hot pursuit 2 (2002)

dsx2020u

n00b
Joined
Aug 20, 2020
Messages
2
When i launch need for speed hot pursuit 2 (2002) the game crashes and gives me this error below. I can play NFS HP 2002 with a RX 580, it has screen tearing, forcing vsync in driver menu doesn't work, and enhanced sync has stuttering, but at least the game is playable.

Has anyone with a 5700 XT tried playing NFS HP 2002 or any other older games to test compatibility?

pc specs
cpu: ryzen 2600x, stock speeds
gpu: sapphire pulse 5700 xt 8gb, driver 20.4.2, stock speeds
motherboard: asrock gaming k4 b450
memory: corsair 16gb 3200mhz ddr4, xmp 2.0 profile
psu: evga 750w
storage: wd blue 4tb hdd
os: windows 7 sp1 x64

---------------------------
Need For Speed Hot Pursuit 2 (exception error)
---------------------------
(Hit Cntrl-C to copy this info to the clipboard)

The thread attempted to read from or write to a virtual address for which it does not have the appropriate access.

Version: 242
EIP = 0x6359957B
ESP = 0x0018F178 EBP = 0x0018F1A4
EAX = 0x00A2D748
EBX = 0x00000001
ECX = 0x000042F8
EDX = 0x0D866C80
ESI = 0x0D86A8EC EDI = 0x000042F4
---------------------------
OK
---------------------------
 

Attachments

  • nfs hp2 error.jpg
    nfs hp2 error.jpg
    45.5 KB · Views: 0
Last edited:

dsx2020u

n00b
Joined
Aug 20, 2020
Messages
2
Just the card. I swap in the rx 580 and the game runs, i swap back the 5700 xt and the game crashes when i launch it.

Also when i play resident evil 6 and resident evil revelations 2 i can't edit the brightness in-game, when i move the sliders the brightness stays the same, it should get darker or brighter. This problem only happens when i use the 5700 xt, the rx 580 doesn't have this brightness bug.

pc specs
cpu: ryzen 2600x, stock speeds
gpu: sapphire pulse 5700 xt 8gb, driver 20.4.2, stock speeds
motherboard: asrock gaming k4 b450
memory: corsair 16gb 3200mhz ddr4, xmp 2.0 profile
psu: evga 750w
storage: wd blue 4tb hdd
os: windows 7 sp1 x64
 

mvmiller12

Gawd
Joined
Aug 7, 2011
Messages
994
Just the card. I swap in the rx 580 and the game runs, i swap back the 5700 xt and the game crashes when i launch it.

Also when i play resident evil 6 and resident evil revelations 2 i can't edit the brightness in-game, when i move the sliders the brightness stays the same, it should get darker or brighter. This problem only happens when i use the 5700 xt, the rx 580 doesn't have this brightness bug.

pc specs
cpu: ryzen 2600x, stock speeds
gpu: sapphire pulse 5700 xt 8gb, driver 20.4.2, stock speeds
motherboard: asrock gaming k4 b450
memory: corsair 16gb 3200mhz ddr4, xmp 2.0 profile
psu: evga 750w
storage: wd blue 4tb hdd
os: windows 7 sp1 x64

There's really only 2 things to suggest:

1) With the 5700XT, reboot into Windows Safe Mode and run DDU (Display Driver Uninstaller) and then let THAT reboot you back into normal mode. Then reinstall the current Windows driver set (20.8.2 as of now) and see if the problem persists

2) If the problem persists, submit a bug report to AMD. They are very much monitoring bug reports for the 5000 series cards right now due to the earlier media blow up regarding buggy drivers.

Something else that might help (but probably won't) - bite the bullet and upgrade to Windows 10. Shouldn't cost you a dime, just some time.
 
Top