550 with Barracuda Spam& Virus Firewall

Joined
Feb 22, 2009
Messages
928
Guys
I am having problems sending out emails from my postfix/mysql to barracuda Spam& Virus Firewall 300 I get 550 and the email server and barracuda is setting with internal IP of 192.168.60.x address and with 2 different real world static IP's. How do I correct this issue?
 

k1pp3r

[H]F Junkie
Joined
Jun 16, 2004
Messages
8,254
Are you on their blacklist? http://www.barracudacentral.org/lookups

Are you using static or dynamic public IP's?
Is your public IP different from your WAN IP?
Does your mail server (Device sending out to the internet) have all required DNS and PTR records in place?
 

ND40oz

[H]F Junkie
Joined
Jul 31, 2005
Messages
12,671
Are you just trying to relay through it? You may need to whitelist whatever the IP is of postfix/mysql box so that it'll allow them to send mail through it. What do the logs show?
 
Joined
Feb 22, 2009
Messages
928
this is what I am getting:

mail postfix/smtp[16833]: 690E7581E5F: to=<SShorter@ccc.com>, relay=192.168.60.20[192.168.60.20]:587, delay=0.4, delays=0.04/0.02/0.21/0.13, dsn=5.0.0, status=bounced (host 192.168.60.20[192.168.60.20] said: 550 No such domain at this location (SShorter@ccc.com) (in reply to RCPT TO command)

This is in my mail log
 

MadJuggla9

2[H]4U
Joined
Oct 9, 2002
Messages
3,515
Is there a DNS pointing to your mail server's public IP (DNS entries are not generally CIDR friendly). Also what is 'command'?

Are you running a local server on windows and trying to publicly relay? Some mail server work and resolve as a mail server but do not resolve on a public level if they are locally addressed on your lan.

For example I can setup myemail@server.me emails all day long on a local server and as long as your on my local network you can send/receive from the generic domain, but if you try on the WAN it will not know to resolve to your NAT'd IP
 
Joined
Feb 22, 2009
Messages
928
there is dns pointing to my mail server public IP and I am running postfix/mysql on ubuntu mail server. Plus I am running nat on the mail server I am using mikrotik for my firewall. I can receive ok but just cant send out.
 

k1pp3r

[H]F Junkie
Joined
Jun 16, 2004
Messages
8,254
550 No such domain at this location

That indciates that domain has not been added to the barracuda accepted domains.
 

MadJuggla9

2[H]4U
Joined
Oct 9, 2002
Messages
3,515
If you can receive mail then your DNS is working properly from the WAN side as it can forward to your local network.

What address are you sending mail to/from...for example I see ccc.com as the host and I'm pretty sure you don't own ccc.com.

Can you send mail directly from yourself to yourself? If you have webmail or a client setup, sending from abc@yourdomain.com to 123@yourdomain.com ?

No matter my issues in the past I could always send to/from my own made up domain on the LAN side, notice that it never had to rely on external DNS for routing.
 

AeonF1

[H]ard|Gawd
Joined
Aug 25, 2002
Messages
2,020
If you don't put in the IP of the sending mail server into the Barracuda, the Barracuda will think it is inbound mail when it is actually outbound mail, thus is why you are getting the domain does not exist error as the Barracuda is assuming this is inbound mail going to a domain that it doesn't manage because its coming from an unknown mail forwarder.

In the menus, Head to Basic->Outbound, and under "Relay using trusted IP/Range" place the IP of your mail server there with a netmask of 255.255.255.255 (using 255.255.255.0 will allow everyone in that /24 network to forward mail to the Barracuda, which you DON'T want). You also want to exempt your mail server from Rate Control under Block/Accept->Rate Control or else you will only be able to send out a total of 50 emails per 30 minutes from that server or whatever number Rate Control is set at.
 

AeonF1

[H]ard|Gawd
Joined
Aug 25, 2002
Messages
2,020
550 No such domain at this location

That indciates that domain has not been added to the barracuda accepted domains.

That only applies to inbound mail, he's having issues sending outbound mail.
 
Joined
Feb 22, 2009
Messages
928
I got it fix it was in side of barracuda because I could not relay from mail server to cuda so inside of the cuda I had to allow Relay Using Trusted IP/Range of my mail server in there to send out email.
 
Top