2700X never seems to throttle down?

Copyright

Supreme [H]ardness
Joined
Nov 17, 2000
Messages
6,003
Noticed my 2700x seems to stay at 4050 or higher on all cores all the time. Not sure why but recently it stopped boosting to 4.35ghz but my guess is the latest bios I used caused this. It ran fine with first release.
 

Algrim

[H]ard|Gawd
Joined
Jun 1, 2016
Messages
1,731
Any possibility of rolling your BIOS revision back to working configuration so you can confirm?
 

thebufenator

[H]ard|Gawd
Joined
Dec 8, 2004
Messages
1,367
Are you running hwinfo in the background to monitor the highest clocks reached per core?
 

cybereality

[H]F Junkie
Joined
Mar 22, 2008
Messages
8,789
Enable AMD Cool n' Quiet in the BIOS settings and also enable Balanced Mode in Windows power options.
 

Copyright

Supreme [H]ardness
Joined
Nov 17, 2000
Messages
6,003
Enable AMD Cool n' Quiet in the BIOS settings and also enable Balanced Mode in Windows power options.

Both already enabled. PC just won't hit 4.35 like ti used to.. Cores all stay pretty solid around 4050 all the time but will jump up as high as 4.225 It was hitting 4.35 on day one.
 

sirmonkey1985

[H]ard|DCer of the Month - July 2010
Joined
Sep 13, 2008
Messages
22,230
the clock speeds won't really drop, but your cpu voltage should be dropping so check your idle voltage. there is a way to lower the clocks using the pstate settings in the bios but from my experience the amount of work to actual idle power usage savings wasn't worth it due to the way windows constantly moves applications between threads forcing the cpu into a higher pstate.

just as an example at idle my r5 1600 sits at the normal 3.4Ghz @ 1.162v.. full load same 3.4Ghz but at 1.31v. currently at idle each core is using less then 1w while the SoC is using 10-20w.. total package wattage between 20-35w.
 

thebufenator

[H]ard|Gawd
Joined
Dec 8, 2004
Messages
1,367
Try loading up hwinfo and letting it run in the background.

It will store the highest clocks it sees.....and responds pretty quick.
 

Shadowed

Limp Gawd
Joined
Mar 21, 2018
Messages
506
In Windows Power Settings check CPU power management.

You have Minimum and Maximum percentages. Try setting Maximum below 100% and see what happens.

Minimum should be at 5%.
 

Copyright

Supreme [H]ardness
Joined
Nov 17, 2000
Messages
6,003
In Windows Power Settings check CPU power management.

You have Minimum and Maximum percentages. Try setting Maximum below 100% and see what happens.

Minimum should be at 5%.

I will check but it was using Ryzen's power setting I believe.. I did also move over to a Samsung Pro 970 SSD...
 

Copyright

Supreme [H]ardness
Joined
Nov 17, 2000
Messages
6,003
Try loading up hwinfo and letting it run in the background.

It will store the highest clocks it sees.....and responds pretty quick.

I will give that a go as well.. It was easily seen in Ryzen Master teh first time I saw it.
 

Copyright

Supreme [H]ardness
Joined
Nov 17, 2000
Messages
6,003
So I think I have figured out a few things. One I tested and found it true. Setting CPU to minimum allows it to clock down to 2ghz or so. Now it's boosting again to 4.35! I did do a windows reload with a new drive shortly after my bios update. Now my voltages are still not low when the CPU drops down. It never drops below 1.31 even when cpu speed drops. It will spike to nearly 1.5V. When it was running hte CPU at 4ghz nearly all the time the voltages were actually more stable and didn't spike as high. It's possible that overdrive being set to auto on my board is causing these voltage issues. My old bios did not have overdrive as an option. I plan to go and disable it.

The one thing I don't know.. the bios has a setting called "MODE 0"... this is set to auto I believe. This is in the NBIO setting section. I have no idea what this is for.
 

Rvenger

2[H]4U
Joined
Sep 12, 2012
Messages
2,564
Had the same issue. Rolled back to release pinnacle ridge BIOS and all is good.
 

Ebernanut

[H]ard|Gawd
Joined
Dec 15, 2010
Messages
1,569
So I think I have figured out a few things. One I tested and found it true. Setting CPU to minimum allows it to clock down to 2ghz or so. Now it's boosting again to 4.35! I did do a windows reload with a new drive shortly after my bios update. Now my voltages are still not low when the CPU drops down. It never drops below 1.31 even when cpu speed drops. It will spike to nearly 1.5V. When it was running hte CPU at 4ghz nearly all the time the voltages were actually more stable and didn't spike as high. It's possible that overdrive being set to auto on my board is causing these voltage issues. My old bios did not have overdrive as an option. I plan to go and disable it.

The one thing I don't know.. the bios has a setting called "MODE 0"... this is set to auto I believe. This is in the NBIO setting section. I have no idea what this is for.

According to The Stilt over on OCN Mode 0 is related to linux somehow but he wasn't sure exactly what it does.
 
Top