10700k running at 3.2-4ghz in task manager. CPU-Z reports correct mhz though. Why?

jarablue

Gawd
Joined
May 31, 2003
Messages
849
Hey guys. I just noticed that in windows task manager. On the cpu screen. My speed is going anywhere from 3.2 to 4k mhz. It is not staying pegged at 4700mhz that CPUZ is reporting.

Is there a reason why? Shouldn't my processor stay at a minimum 4.7k mhz in task manager? Why is the cpu speed bouncing up and down there but pegged pretty solid in cpuz?

My power profile is high performance. I am not sure what's going on.

Thanks.
 

Logan M

Weaksauce
Joined
Nov 25, 2016
Messages
117
Is that with apps running in the background to make it boost up to that speed? Does CPUZ show your processor at 4.7 ghz constantly because it shouldn’t.
 

jarablue

Gawd
Joined
May 31, 2003
Messages
849
I thought if I set my power profile to high perf, it should do that. Yes. Cpuz shows my cpu at 4.7 constantly. Tiny changes here and there but pretty much at 4.7. Why should cpuz show anything less than 4.7 if I have my power profile set to high perf?
 

70 Polara

Limp Gawd
Joined
Jul 31, 2004
Messages
221
I've often noticed this with the Windows 10 task manager as well.....the CPU speeds displayed don't match CPU-Z. As an example here is my relic running Prime95.................
Untitled.jpg
 

Logan M

Weaksauce
Joined
Nov 25, 2016
Messages
117
I thought if I set my power profile to high perf, it should do that. Yes. Cpuz shows my cpu at 4.7 constantly. Tiny changes here and there but pretty much at 4.7. Why should cpuz show anything less than 4.7 if I have my power profile set to high perf?

Well I just tested it on my system and I was under the impression it wouldn’t peg at max boost clock without applications running with just high performance enabled but I was wrong. Both CPUZ and task manager are showing 100% boost clocks on my system so something odd is definitely going on with yours.
 

jarablue

Gawd
Joined
May 31, 2003
Messages
849
Yeah. In cpuz I noticed the clock speed drops to 800mhz also for some reason. Really quickly then goes back to 4700 4800mhz.

I looked up online and apparently windows task manager is notoriously bad for reporting the correct speed. Not sure if there is something wrong with my system. But the speed dropping to 800mhz could be power management no? This is a 10700k and Asus 490-A prime board.
 
Top