[H]ard|Forum  

Go Back   [H]ard|Forum > Bits & Bytes > Operating Systems

Reply
 
Thread Tools Search this Thread
  #1  
Old 03-11-2009, 12:28 PM
blisstik Limp Gawd, 10.3 Years
 
Status: blisstik is offline  
Windows 7 64-bit Full Screen OpenGL Stutter Fix for ATi Cards

Update: I just uninstalled 9.2 and installed 9.3 and OpenGL works without any issues

The atioglxx.dll version from 9.3 is 6.14.10.8543.
The atioglxx.dll version from 8.9 is 6.14.10.7976.

http://game.amd.com/us-en/drivers_catalyst.aspx
__________________

I know some of you still play your old school OpenGL games such as Quake 3, Doom 3 and Unreal Tournament. The problem is that using the latest ATi Catalyst 9.2 driver (and earlier) for Vista x64 (works fine on Windows 7 x64 except OpenGL) causes these games to flicker continuously, rendering the game unplayable.

I've tried installing the 8.12 preview driver for Windows 7 but that doesn't work either. Searching the interwebs seem to point ATi video card owners to install the ATi Catalyst 8.9 driver for Vista x64.

Well, instead of uninstalling the whole 9.2 package to install ancient 8.9, why not just extract the 8.9 OpenGL driver and use it on the 9.2? The advantage is that you still use the latest D3D drivers for newer games.

Assumptions:
-using Windows 7 Beta 64-bit
-using ATi based video card
-using ATi Catalyst 9.2 or earlier

Instructions:
1. Search for "8.9 Catalyst x64 Vista" and download that package

2. Use 7-Zip to extract the files inside the package exe

3. Inside the extracted files, search and copy the two files below
atioglxx.dl_ (about 4MB)
atioglxx.xml (very small size)

4. For the tutorials sake, paste the two files in the root of your C:\

5. Start command prompt, go to C: then type "expand atioglxx.dl_ atioglxx.dll" (you will notice the dll file is now about 9MB)

8. Go to C:\Windows then search for the dll and xml files one-by-one using the top right search box

9. Go to each of the folders that contain the dll and xml files, take ownership and overwrite them

10. Start your favorite old school OpenGL game in full screen without flicker!

This works for UT99 using the latest OpenGL driver.
__________________
http://www.heatware.com/eval.php?id=35774

Last edited by blisstik; 03-18-2009 at 08:28 PM.
Reply With Quote
  #2  
Old 03-11-2009, 06:56 PM
RogueTrip 2[H]4U, 11.8 Years
 
Status: RogueTrip is offline  
This flicker affects opengl games with nVidia cards as well under windows 7 and NON-window update drivers

The way I found to fix it is to download the newest rivatuner (works with ATI cards also). Go to openGL settings under the driver settings, move to the "Back / depth buffering" tab and where it shows "Back buffer flipping mode" select "block transfer" instead of auto. Play game, enjoy
__________________
///..Millennium..><..P3 1400S..><..0.5GB..><..3Dfx Voodoo4..><..SBLive!..><..WD1600JB..\\\
///..8.1 Pro x64..<>..i7 4790K...<>..16GB..<>..nVidia GTX-970..<>..Accumulated 4.375 TB..\\\
non-PC: PS3, PSP, PS2, PS1, Wii, N64, NGC, SNES, DSLite, GBA, GBµ, GB, SDC, SG, SGG
Reply With Quote
  #3  
Old 03-11-2009, 10:05 PM
blisstik Limp Gawd, 10.3 Years
 
Status: blisstik is offline  
Quote:
Originally Posted by RogueTrip View Post
This flicker affects opengl games with nVidia cards as well under windows 7 and NON-window update drivers

The way I found to fix it is to download the newest rivatuner (works with ATI cards also). Go to openGL settings under the driver settings, move to the "Back / depth buffering" tab and where it shows "Back buffer flipping mode" select "block transfer" instead of auto. Play game, enjoy
I tried using RivaTuner but the OpenGL settings are nowhere to be found. I'm using a 4850. I'm not sure if it works on other ATi cards. It's worth a try rather than the longer fix above.
__________________
http://www.heatware.com/eval.php?id=35774
Reply With Quote
  #4  
Old 03-12-2009, 12:07 AM
RogueTrip 2[H]4U, 11.8 Years
 
Status: RogueTrip is offline  
I always heard it worked for ATI cards, so you have nothing here:


Just click that lil arrow by customize and it should bring up your OpenGL tweak settings
__________________
///..Millennium..><..P3 1400S..><..0.5GB..><..3Dfx Voodoo4..><..SBLive!..><..WD1600JB..\\\
///..8.1 Pro x64..<>..i7 4790K...<>..16GB..<>..nVidia GTX-970..<>..Accumulated 4.375 TB..\\\
non-PC: PS3, PSP, PS2, PS1, Wii, N64, NGC, SNES, DSLite, GBA, GBµ, GB, SDC, SG, SGG
Reply With Quote
  #5  
Old 03-12-2009, 12:36 AM
Sovereign 2[H]4U, 9.7 Years
 
Status: Sovereign is offline  
Thanks for the heads up, but "No supported drivers detected for this display adapter." Did you stuff the latest Vista x64 drivers in there? I have the "official" Windows 7 181s.
__________________
Play [H]ard
2600k @ 4.4GHz (H212+) :: 16GB DDR3-1600 :: Gigabyte GeForce GTX 780OC :: Asus P8P67 Deluxe :: Samsung 840EVO 250GB :: 300GB VR :: 3x2TB SpinPoint RAID5/PERC5i :: 500GBx2 RST RAID1 :: 2TB WD GP :: X-Fi XtremeMusic :: Dell U3014:: Dell WFP2408 :: Acer 22" :: Thermaltake Armor Black :: Logitech Z5500 5.1
Work [H]ard...ish
Core 2 Duo @ 2.53GHz :: 8GB DDR3 @ 1067MHz :: Radeon 4670 1GB :: Intel PM45 Chipset :: Samsung 840 EVO 750GB :: Integrated Audio :: BD-ROM/DVD Burn :: 16.0" RGBLCD 1920x1080
Reply With Quote
  #6  
Old 03-12-2009, 09:54 AM
RogueTrip 2[H]4U, 11.8 Years
 
Status: RogueTrip is offline  
Quote:
Originally Posted by Sovereign View Post
Thanks for the heads up, but "No supported drivers detected for this display adapter." Did you stuff the latest Vista x64 drivers in there? I have the "official" Windows 7 181s.
Yes, they are Vista x64 drivers I use, as I stated above, this happens with NON-windows update drivers (the Prerelease 1.1 and such) so every vista x64 driver I've tried does this on windows 7 (7000 and 7048 builds). I haven't tried the Win7 181 drivers to see if they are flawed, Can you play OpenGL games like Doom3 okay without heavy flickering going on?

I use the Vista x64 due to being the most up to date with most bug fixes over windows 7. This OpenGL issue is the only issue I can find with the drivers.
__________________
///..Millennium..><..P3 1400S..><..0.5GB..><..3Dfx Voodoo4..><..SBLive!..><..WD1600JB..\\\
///..8.1 Pro x64..<>..i7 4790K...<>..16GB..<>..nVidia GTX-970..<>..Accumulated 4.375 TB..\\\
non-PC: PS3, PSP, PS2, PS1, Wii, N64, NGC, SNES, DSLite, GBA, GBµ, GB, SDC, SG, SGG
Reply With Quote
  #7  
Old 03-12-2009, 10:01 AM
Sovereign 2[H]4U, 9.7 Years
 
Status: Sovereign is offline  
Well my device manager says the drivers I have are "Prerelease WDDM 1.1" so I'll check on the OpenGL but given that I bet they will have the same problem...
__________________
Play [H]ard
2600k @ 4.4GHz (H212+) :: 16GB DDR3-1600 :: Gigabyte GeForce GTX 780OC :: Asus P8P67 Deluxe :: Samsung 840EVO 250GB :: 300GB VR :: 3x2TB SpinPoint RAID5/PERC5i :: 500GBx2 RST RAID1 :: 2TB WD GP :: X-Fi XtremeMusic :: Dell U3014:: Dell WFP2408 :: Acer 22" :: Thermaltake Armor Black :: Logitech Z5500 5.1
Work [H]ard...ish
Core 2 Duo @ 2.53GHz :: 8GB DDR3 @ 1067MHz :: Radeon 4670 1GB :: Intel PM45 Chipset :: Samsung 840 EVO 750GB :: Integrated Audio :: BD-ROM/DVD Burn :: 16.0" RGBLCD 1920x1080
Reply With Quote
  #8  
Old 03-12-2009, 11:43 PM
Sovereign 2[H]4U, 9.7 Years
 
Status: Sovereign is offline  
Sorry for the doublepost, but I want everyone to know: I am not affected by this issue on the "official" Win7 NVIDIA drivers. Running Build 7048 x64. Doom3 runs like butter on my 9800GX2 on all maxed out settings. No flicker.
__________________
Play [H]ard
2600k @ 4.4GHz (H212+) :: 16GB DDR3-1600 :: Gigabyte GeForce GTX 780OC :: Asus P8P67 Deluxe :: Samsung 840EVO 250GB :: 300GB VR :: 3x2TB SpinPoint RAID5/PERC5i :: 500GBx2 RST RAID1 :: 2TB WD GP :: X-Fi XtremeMusic :: Dell U3014:: Dell WFP2408 :: Acer 22" :: Thermaltake Armor Black :: Logitech Z5500 5.1
Work [H]ard...ish
Core 2 Duo @ 2.53GHz :: 8GB DDR3 @ 1067MHz :: Radeon 4670 1GB :: Intel PM45 Chipset :: Samsung 840 EVO 750GB :: Integrated Audio :: BD-ROM/DVD Burn :: 16.0" RGBLCD 1920x1080
Reply With Quote
  #9  
Old 03-13-2009, 12:55 AM
RogueTrip 2[H]4U, 11.8 Years
 
Status: RogueTrip is offline  
Quote:
Originally Posted by Sovereign View Post
Sorry for the doublepost, but I want everyone to know: I am not affected by this issue on the "official" Win7 NVIDIA drivers. Running Build 7048 x64. Doom3 runs like butter on my 9800GX2 on all maxed out settings. No flicker.
Yep, as I was saying, this only affect Vista x64 drivers on Windows 7.

Prerelease WDDM 1.1 drivers are Windows Update drivers, as I've been trying to point out. Vista x64 are NON-windows Update drivers.

Install any of the Vista x64 drivers on windows 7 x64 and you will get flicker, and this is the fix for it.
__________________
///..Millennium..><..P3 1400S..><..0.5GB..><..3Dfx Voodoo4..><..SBLive!..><..WD1600JB..\\\
///..8.1 Pro x64..<>..i7 4790K...<>..16GB..<>..nVidia GTX-970..<>..Accumulated 4.375 TB..\\\
non-PC: PS3, PSP, PS2, PS1, Wii, N64, NGC, SNES, DSLite, GBA, GBµ, GB, SDC, SG, SGG
Reply With Quote
  #10  
Old 03-13-2009, 01:25 AM
Sovereign 2[H]4U, 9.7 Years
 
Status: Sovereign is offline  
Oh I thought the NVIDIA drivers were "non-WU." Also, is there anything "wrong" with the NVIDIA Windows 7 drivers that you'd want to use the Vista x64 ones?
__________________
Play [H]ard
2600k @ 4.4GHz (H212+) :: 16GB DDR3-1600 :: Gigabyte GeForce GTX 780OC :: Asus P8P67 Deluxe :: Samsung 840EVO 250GB :: 300GB VR :: 3x2TB SpinPoint RAID5/PERC5i :: 500GBx2 RST RAID1 :: 2TB WD GP :: X-Fi XtremeMusic :: Dell U3014:: Dell WFP2408 :: Acer 22" :: Thermaltake Armor Black :: Logitech Z5500 5.1
Work [H]ard...ish
Core 2 Duo @ 2.53GHz :: 8GB DDR3 @ 1067MHz :: Radeon 4670 1GB :: Intel PM45 Chipset :: Samsung 840 EVO 750GB :: Integrated Audio :: BD-ROM/DVD Burn :: 16.0" RGBLCD 1920x1080
Reply With Quote
  #11  
Old 03-13-2009, 12:34 PM
blisstik Limp Gawd, 10.3 Years
 
Status: blisstik is offline  
I haven't tried the WDM drivers from Windows Update for Windows 7. I'm pretty skeptical with the performance of pre-release drivers when it comes to gaming.

If anyone can reply here using stock WDM drivers, let us know your setup!
__________________
http://www.heatware.com/eval.php?id=35774
Reply With Quote
  #12  
Old 03-13-2009, 03:16 PM
HammerAZ Limp Gawd, 5.7 Years
 
Status: HammerAZ is offline  
I've been using the ATI Windows 7 Beta drivers since my install of Windows 7

http://support.amd.com/us/kbarticles...etaDriver.aspx

Are these the same as the Windows Update drivers?

I've found that my gaming has been just as good, if not better than my GF's rig - and short of my .6 OC, and HDD's they're the same.
Reply With Quote
  #13  
Old 03-18-2009, 08:29 PM
blisstik Limp Gawd, 10.3 Years
 
Status: blisstik is offline  
Update: I just uninstalled 9.2 and installed 9.3 and OpenGL works without any issues

The atioglxx.dll version from 9.3 is 6.14.10.8543.
The atioglxx.dll version from 8.9 is 6.14.10.7976.

http://game.amd.com/us-en/drivers_catalyst.aspx
__________________
http://www.heatware.com/eval.php?id=35774
Reply With Quote
  #14  
Old 03-19-2009, 11:16 AM
HammerAZ Limp Gawd, 5.7 Years
 
Status: HammerAZ is offline  
The 9.3's solved my EVE online display issues. Working great!
Reply With Quote
  #15  
Old 03-23-2009, 12:29 AM
antiflux n00bie, 9.0 Years
 
Status: antiflux is offline  
Hey all, I finally got 9.3 (CCC and driver) to work with my ATI Mobility Radeon X1200 in Windows 7 64-bit (Build 7057) ... I didnt use the modder program. Quakelive seems to be running fine without the flickering problem in full screen mode. Also the game is MUCH smoother than it was in Windows XP SP3 32-bit.

What I did:

1) As per OzzieXP's post (on driverheaven.net forums) I removed the 6.1 references in both of the .inf files (C7_77072.inf & CH_76829.inf).
i.e. changed anything that displayed "NTamd64.6.1" to "NTamd64.6.1"

2) Manually edited the .inf (C7_77072.inf & CH_76829.inf) with my device hardware information
e.g. "ATI Radeon X1200 Series" = ati2mtag_RS690, PCI\VEN_1002&DEV_791F

you can find the device ID in device manager under the device properties...

THANKS NOW I CAN PLAY QUAKELIVE AGAIN! =)

http://img14.imageshack.us/img14/7066/worksn.jpg

Edit: Also it pisses me off that ATI doesn't allow me to install this without modding the driver even though the driver works PERFECTLY...
Reply With Quote
  #16  
Old 10-25-2009, 11:03 AM
overclocky n00bie, 5.1 Years
 
Status: overclocky is offline  
Omg, you saved me!
I had this memory leaking issue with KOTOR under windows 7, but then I extracted .dll file from 9.7 catalyst and put the .dll file in the KOTOR installation file. Voila, it works
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 05:49 AM.


Powered by Vbulletin - Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2000 - 2014 KB Networks, Inc.